mysqli для php в стеке LAMP Ubuntu 8.04

Asked
Viewd18625

5

Кто-нибудь знает, как в Ubuntu 8.04 с PHP 5 и MySQL 5.0 включить / установить пакет / расширения mysqli?

Я бы предпочел сохранить существующие установки, но, если необходимо, переустановлю заново.

Я понимаю, что технически это не связано с программированием, но, как мне кажется (с некоторой натяжкой, возможно), это позволяет программировать? надежды

Спасибо за любую помощь, которую вы можете оказать.

4 ответов

3

Возможно, вам придется установить php с опцией mysqli: apt-get install php5-mysqli

  • Эта ссылка, похоже, посвящена установке стека LAMP, который у меня уже есть, и ничего не говорит об установке / включении mysqli для php. Но все же спасибо, это было интересное чтение :)

    David says reinstate Monica03 апреля 2009, 13:19
9

В Ubuntu Hardy (8.04) mysqli является частью пакета php5-mysql вместе со стандартной библиотекой mysql и pdo - см. http://packages.ubuntu.com/hardy/php5-mysql для получения дополнительной информации.

 sudo apt-get install php5-mysql
 
2

Из документации PHP.

Чтобы убедиться, что расширение mysqli для PHP включено, вам необходимо настроить исходный код PHP для использования mysqli. Это достигается запуском скрипта configure с параметром --with-mysqli = mysql_config_path / mysql_config перед сборкой PHP. Это включит mysqli и будет использовать клиентскую библиотеку MySQL (libmysql) для связи с сервером MySQL.

Но поскольку вы используете Ubuntu. Вы можете просто установить пакет mysqli. Подробности здесь.

 sudo apt-get install php5-mysqli
 
  • Вы можете попробовать установить php5-pdo, если PDO подходит для вашего приложения. Думаю, вам просто понадобится apt-get install php5-pdo-mysql, но я точно не могу вспомнить название пакета.

    David Snabel-Caunt03 апреля 2009, 13:31
  • Приятно, но когда я впервые посмотрел, его не было (по какой-то причине). Или я его пропустил… blush ммм: sudo apt-get mysqli дает «E: пакет php5-mysqli не имеет кандидата на установку». Предлагаемая замена - пакет php-mysql - уже является последней версией.

    David says reinstate Monica03 апреля 2009, 13:27
  • Прошу прощения, но как? Боюсь, что сейчас я неуверен в себе. Мне может понадобиться держать за руку. Или поездка на спине по сложным местам. blush

    David says reinstate Monica03 апреля 2009, 13:21