Все вопросы: [rubygems]

230 вопросов

похожие теги:
1
голосов
1ответов
1895 просмотров

gltail "Missing gem net-ssh"

I'm attempting to get gltail set up on my local system to monitor logs remotely. I've got all the dependencies installed, but when I go to run gltail ... ./gl_tail configfile ../config.yaml I get this output: Missing gem net-ssh. Ubuntu: sudo gem install -y net-ssh -r .. which I've done ...

4
голосов
4ответов
4062 просмотров

Resolve multiple versions of rubygems

I have what looks like multiple versions of rubygems installed on my machine, when i gem list i see all my gems, but when i go to run scripts, i get error messages like Missing these required gems: SystemTimer Is there any methodology I can follow to remove all versions of rubygems but one?...

0
голосов
3ответов
446 просмотров

Help with RubyGems (the package manager)

I really need help with Rubygems (that's the package manager for ruby). Since I'm behind a proxy, I've given up all hope of it working automatically, so I had to download a lot of packages manually and install them for rails to install. Now, I'm getting an error message: Rails requires RubyGems&...

15
голосов
5ответов
6367 просмотров

Using Gems with MacRuby

How do you use gems from a MacRuby .5 application on Snow Leopard? Do I need to specify the gem path? If so, how do I do this? Best scenario is to package the gems inside the application so the user would not have to install them when the app is distributed.

3
голосов
2ответов
1993 просмотров

Spree e-Commerce within Existing Application

I'm trying to setup Spree within my application (I'm open to using the Gem or running it in vendor mode). I've reviewed the documentation and the wiki and I'm still a bit confused as to how it might work within my existing application. I have no problem using a separate database for Spree and c...

0
голосов
2ответов
699 просмотров

RubyZip - files from different directories have path in zip

I'm trying to use RubyZip to package up some files. At the moment I have a method which happily zips on particular directory and sub-directories. def zip_directory(zipfile) Dir["#{@directory_to_zip}/**/**"].reject{|f| reject_file(f)}.each do |file_path| file_name = file_path.sub(@di...

0
голосов
3ответов
1320 просмотров

How to gemify a Rails (engine) plugin?

I have a engine style Rails plugin from which I can create a gem using Jeweler. But when I require it in my Rails environment (or erb) the models within the plugin are not loaded. I have followed a number of tutorials and read just about everything on the subject. # environment.rb config.gem 'm...

2
голосов
2ответов
775 просмотров

config.gem requires gem?

I have a bunch of config.gem statements in my environment.rb file: config.gem "fastercsv", :version => "~>1.5.0" config.gem "parseexcel", :version => "~>0.5.2" config.gem "geokit", :version => "~>1.4.1" config.gem "facebooker", :version => "~>1.0.50" ... If I do ...

3
голосов
1ответов
2283 просмотров

Ruby on Rails SQLite problem on Windows 7 x64

When I try to do db:create on sqlite database with this db config using Windows 7 x64 development: adapter: sqlite3 database: db/development.sqlite3 timeout: 5000 I get this, kinda funny error unknown error C:/Ruby/lib/ruby/1.8/dl/import.rb:29:in `initialize' C:/Ruby/lib/ruby/1.8/dl/imp...

3
голосов
8ответов
377 просмотров

Which are the precious Rails RubyGems that Railers can't live without?

There are a lot of interesting gems beyond the classic Rails gem pack: cucumber, formtastic, rspec, shoulda, coulda, webrat, selenium, will_paginate, authlogic, searchlogic, inherited resources ... Let's make some effort to catalog the best Rails gems on SO. I'm new to the Rails community and a...

3
голосов
2ответов
354 просмотров

STL support in Ruby

Anyone heard of a good standard template library in Ruby? Or any wrapper exists? Thanks!

2
голосов
6ответов
3353 просмотров

require library returns 'missing file' message

I have a small application which I created using jeweler. The jeweler generates a lib/ directory, where I suppose to write my code. This gem I'm creating depends on the httparty gem, so, in my Rakefile I put Jeweler::Tasks.new do |gem| gem.add_dependency('httparty', '>= 0.4.5') .....

1
голосов
2ответов
473 просмотров

Necessary steps for using a gem (e.g. json) in Ruby on Rails app?

I'm having trouble getting rubygems to work in my Rails app. Specifically, I'm trying to use the json gem, documented here: http://flori.github.com/json/ I can successfully use JSON.parse() in IRB and script/console but not in my rails app. I know it's some combination of config.gem 'json' in ...

0
голосов
1ответов
602 просмотров

Netbeans doesn't recognize ruby gems installed using Terminal

I have installed a GEM called "Ziya" using the terminal in Mac OSx. However, when I open the application using the Netbeans, it says that the GEM cannot be found. If I install Ziya using the GEM manager, I get the following error and the GEM doesn't get installed, WARNING: Installing to ~/.g...

2
голосов
3ответов
582 просмотров

Incompatibily between ruby and mysql gem

When trying to install the mysql gem from cPanel on my website, I get an error saying that the gem requires Ruby>= 1.8.6. This is a shared server and the version of Ruby is 1.8.5 and can't be upgraded. I do not have shell access and it seems the only way for me to install a gem is through the ...

0
голосов
3ответов
974 просмотров

RMagick installation failed in Ubuntu 9.04

I already installed the following: imagemagick libmagickwand-dev but still i get this error. ====================================================================== Mon 05Oct09 19:36:06 This installation of RMagick 2.12.0 is configured for Ruby 1.8.7 (i486-linux) and ImageMagick 6.4.5 Q16 ==...

0
голосов
1ответов
70 просмотров

other alternative texthelpers in rails

I have text input I get from a variety of sources which is not HTML but is simple text. I've tried using Redcloth to fit this with HTML tags to that it integrates nicely into my site, but it doesn't get bullet points or paragraphs... I checked around an found some text helpers built in, but thos...

1
голосов
1ответов
1769 просмотров

Cannot load gem in IronRuby

I already removed all environment variables and ruby/ironruby directories and reinstalled it from scratch. And then I installed mocha through igem. Here are my outputs. $ ir IronRuby 0.9.1.0 on .NET 2.0.50727.3082 Copyright (c) Microsoft Corporation. All rights reserved. >>> require 'm...

0
голосов
1ответов
361 просмотров

why isn't rails (or script/console) seeing my current version of 'gem'?

I'm having trouble getting a working rails console, and I'm not sure why. I've tried to distil my issue and the console output below sums it up : [email protected]:/webapps/cts/current$ ./script/console Loading development environment (Rails 2.3.4) Rails requires RubyGems>= 1.3.2 (you have ...

1
голосов
3ответов
772 просмотров

Multiple rubygems versions

Basically what I need is to install rubygems 1.3.5 on a machine (Debian) with 1.2.0 installed and having no root access. What I've done so far: installed rubygems into $HOME/rubygems and set up GEM_HOME + added bin to the path. So running "which gem" shows me the new binary, not the old one. Als...

14
голосов
1ответов
11147 просмотров

Git replaced all of my LF with CRLF - How do I fix this?

I just ran a git add -A on my first git project. I got back about a thousand responses: "warning: LF will be replaced by CRLF" as it went through each file (Ruby files, some are gems). I deleted my .git directory and tried to disable this default setting by typing this command: git ...

1
голосов
1ответов
776 просмотров

Can't find rmagick gem when required in script

I've recently run into an issue with mod_passenger and gems. I have a couple of gems install and I can find them in my /opt/ruby-enterprise/lib/ruby/gems/1.8/gems directory. One is will_paginate and the other is rmagick. For some reason, when my rails app starts up, it finds will_paginate jus...

7
голосов
7ответов
7523 просмотров

Missing the Rails 2.3.4 gem. Even though it's installed!

Running Snow Leopard. Tried uninstalling, and re-installing. Still getting the same error whenever I run a rake task. mbpro:redmine shereef$ ruby -v ruby 1.8.7 (2009-06-12 patchlevel 174) [i686-darwin10.0.0] mbpro:redmine shereef$ rails -v Rails 2.3.4 mbpro:redmine shereef$ w...

1
голосов
4ответов
4376 просмотров

How to use ruby to get string between HTML <cite> tags?</cite>

Greetings everyone: I would love to get some information from a huge collection of Google Search Result pages. The only thing I need is the URLs inside a bunch of &lt;cite&gt;&lt;/cite&gt; HTML tags. I cannot get a solution in any other proper way to handle this problem so now I am moving to ru...

0
голосов
3ответов
431 просмотров

Keyword searching defaulting to AND

I successfully installed and set it up searchlogic for basic (keyword) searching. I have the following problem: @search = Proposal.search(params[:search]) @proposals = @search.all The above code works properly if I type in a keyword such as "red". It will bring up everything with red keyword. ...

9
голосов
3ответов
647 просмотров

Why is it "wrong to require rubygems"?

According to this post, requiring rubygems is an antipattern. require 'rubygems' The argument seems to boil down to this: When I use your library, deploy your app, or run your tests I may not want to use rubygems. When you require 'rubygems' in your code, you remove my ability to m...

2
голосов
2ответов
629 просмотров

Ruby gem for unix 'at' command

I've found the whenever gem quite useful for working with cron from Ruby. Does anyone know of a similar project for at/batch?

0
голосов
1ответов
86 просмотров

Problem including gems in Rails 2.3?

My Rails app uses the TMail plugin, but it requires a modification to Attachment.rb. The modification is recognized and loaded by Rails on my development machine, but in the production environment on my hosting provider (Rails Playground), the system version of TMail is loaded and not our custom...

2
голосов
4ответов
1466 просмотров

Hosting Help- Custom Gems on DreamHost

I am attempting to deploy a RoR app using Passenger onto my DreamHost hosting account, but am having trouble getting it up and running. My application requires two custom gems 'amazon-ecs' and 'nokogiri.' As per the instructions on the DreamHost wiki (http://wiki.dreamhost.com/Freezing_Gems) I f...

3
голосов
3ответов
1939 просмотров

how to control gems vs plugins loading order in Rails

I have a plugin that must be loaded before resource_controller. The reason is that Resourcecontroller tries to load ApplicationController and it depends on the said plugin (and will fail to load if plugin's init.rb was not loaded yet). The problem is that ResourceController comes from a gem and ...