0
голосов
1ответов
532 просмотров

Ruby 1.8.6 BigDecimal.to_f всегда возвращает 0,0 в Solaris

Я обнаружил очень странную ошибку.Я использую Solaris 10, использую Ruby Enterprise Edition (ruby 1.8.6 (2008-08-08 patchlevel 286) [i386-solaris2.10]) с Rails 2.3.4.У меня очень странная ошибка.В irb: irb(main):001:0> require 'bigdecimal' => true irb(main):002:0> b = BigDecimal.new(...

81
голосов
4ответов
35601 просмотров

Determine ruby version from within Rails

Is there a way to determine what version of Ruby is running from within Rails (either on the web or through script/console)? I have Ruby 1.8.6 installed but I've also installed Ruby Enterprise Edition 1.8.7-20090928 and want to ensure that it's using the right installation.

2
голосов
1ответов
434 просмотров

Apache-httpd processes die with segmentation fault on deployment

I'm running Rails 2.3.3 application which is deployed with passenger/mod_rails with ruby-enterprise-1.8.6-20090610 and apache httpd. The problem is that whenever I deploy our application, hundreds of httpd processes start dying. I'm getting this error: [notice] child pid NNNNN exit signal Segm...

11
голосов
3ответов
11490 просмотров

Ruby Enterprise Edition vs Ruby 1.9

I'm planning to build a website that will be a simple CMS where users submit and view postings with videos, photos and text. One decision I want to make is choosing between Ruby Enterprise Edition and Ruby 1.9. Things I care about in order: Performance & Scalability. Compatibility with ex...

0
голосов
1ответов
397 просмотров

Passenger / REE can't find rails, it's in the $PATH, what gives?

I've got a fresh install of Ruby EE (1.8.6-20090610) and Passenger (2.2.5) on Debian Lenny. REE is installed in /opt/ruby-enterprise and it is added to the $PATH of all users through /etc/environment, and PassengerDefaultUser is set to root. The problem is when loading a rails app, the Passenge...

1
голосов
2ответов
447 просмотров

Ruby EE ./installer fails on mysql gem installation

So, installing Ruby Enterprise Edition went fairly smoothly (except for a very odd quirk of the system I'm on, where I had to apt-get install build-essentials because there was no GCC...), but it failed to install any of the database gems properly. I mainly want to use MySQL. Here's the output of...

1
голосов
1ответов
652 просмотров

Weird Ruby Enterprise Edition Problem

I just installed Ruby Enterprise Edition and Passenger on an Ubuntu Hardy 8.04 VPS. As far as I'm aware, the installation was successful. My Rails application is accessible and on the whole, works fine. However, the part of my application where users can post comments using AJAX doesn't work. My ...

2
голосов
5ответов
4420 просмотров

При использовании Ruby Enterprise Edition драгоценные камни не устанавливаются там, где я ожидал

Я только что установил Ruby Enterprise Edition и устанавливаю для него несколько гемов. На сервере также установлен стандартный Ruby 1.8.6. Я добавил /opt/ruby-enterprise-1.8.6-20090201/bin к моему PATH, начав с /usr/bin, где живут ruby и gem. which gem подтверждает это: /opt/ruby-enter...

1
голосов
2ответов
645 просмотров

Есть ли хороший источник данных об использовании Ruby Enterprise Edition в реальных условиях?

Мы добились отличных результатов со стеком Phusion ( Passenger и Ruby Enterprise Edition ), но мне не удалось найти много информации об их использовании в дикие, особенно РЗЭ. Мне бы хотелось что-то вроде высокопрофильных организаций, использующих Rails от WWR или Список Кто использует Cold...