6
голосов
4ответов
6539 просмотров

Репозиторий драгоценных камней Ruby

Я пытаюсь создать репозиторий драгоценных камней на одном из наших локальных серверов. Вот шаги, которые я выполняю, и следовал им из нескольких руководств. 1) Создаю папку BASEDIR / var / www / html / gems 2) sudo cp -r /usr/lib/ruby/gems/1.8/gems/someGem / var / www / html / gems 3) s...

1
голосов
1ответов
969 просмотров

поднять MysqlError;Поднять Mysql :: Error оба работают, как это произошло?

Приветствую Я работал с исключениями mysql и столкнулся с этой интересной проблемой, когда возникшее исключение отвечает на два разных имени исключения.Как это случилось? -daniel #!/usr/bin/env ruby require 'rubygems' require 'mysql' require 'yaml' require 'pp' $config = YAML.load_fil...

6
голосов
3ответов
8215 просмотров

Невозможно установить gemcutter в качестве источника Ruby Gem

Я пытаюсь установить гем мыслящего сфинкса, который находится на gemcutter.org Когда я запускаю команду gem sources -a http://gemcutter.org Я получаю сообщение об ошибке: Error fetching http://gemcutter.org: bad response Not Found 404 (http://gemcutter.org/specs.4.8) Если я изме...

0
голосов
2ответов
167 просмотров

Не работает с более свежими драгоценными камнями

Я работаю над университетским проектом, и мой учитель настроил для него сервер, но после установки Ruby 1.9.x нам пришлось вернуться к Ruby 1.8.x из-за проблемы с Ruby 1.9 / Rails 2.3.4. Теперь каждый раз, когда я создаю приложение Rails, оно всегда использует драгоценные камни Rails 2.2.3. ...

0
голосов
2ответов
2252 просмотров

Ruby требует проблемы

Я пытаюсь запустить драгоценный камень очистки.Я установил sanitize и nokogiri 1.3.3 по мере необходимости, но когда я пытаюсь использовать его в своем application_helper.rb: require 'rubygems' require 'sanitize' Я получаю сообщение об ошибке: MissingSourceFile no such file to load --...

0
голосов
1ответов
964 просмотров

Проблема с Ruby Gem и Sanitize

Я пытаюсь установить очистку драгоценного камня Ruby.Я уже установил nokogiri: >gem list nokogiri *** LOCAL GEMS *** nokogiri (1.4.0) но когда я пытаюсь установить sanitize, я получаю следующую ошибку: >gem install rgrove-sanitize ERROR: Error installing rgrove-sanitize: rgrov...

21
голосов
3ответов
25343 просмотров

Как удалить удаленный источник из удаленных источников gem

Я добавил gemcutter.org в свои исходные коды Rubygems и теперь не знаю, как его удалить. $ gem sources *** CURRENT SOURCES *** http://gemcutter.org http://gems.rubyforge.org/

7
голосов
7ответов
7011 просмотров

Установка gem bcrypt-ruby в Windows

Я пытаюсь установить bcrypt-ruby в Windows Vista. Пока мне удалось установить nmake.exe из статьи базы знаний MS, а cl.exe из Visual Studio 2008 Express. Однако теперь я сталкиваюсь с этой ошибкой: cl -nologo -Wall -I. -IC:/InstantRails/ruby/lib/ruby/1.8/i386-mswin32 -I C:/InstantRail...

9
голосов
2ответов
2478 просмотров

Гем Rails с файлами javascript

Я пытаюсь создать рубиновый драгоценный камень для рельсов из созданного мной плагина.Проблема в том, что в моем плагине «ярлыки» используются несколько файлов javascript, которые для работы должны находиться в каталоге public / javascripts. Как лучше всего сделать эти файлы javascript, наход...

2
голосов
1ответов
1312 просмотров

act_as_audited.Как добавить столбец "комментарий"

Я использую в своем приложении гем actions_as_audited.(Отличный гем для отслеживания изменений объектов модели) Меня попросили поддержать привязку текстового комментария к каждой записи аудита (функциональность аналогична svn commit).И я не понимаю, как этого добиться. Например.Допустим, у...

1
голосов
1ответов
2728 просмотров

Как войти в удаленный каталог в Ruby NET: SFTP?

Как войти в каталог, например, с помощью команды - cd, чтобы работать с удаленными файлами без префикса пути? Вот мой текущий код. Net::SFTP.start do |sftp| sftp.rename!(REMOTE_PATH + "latest.zip", REMOTE_PATH + "latest.back.zip") sftp.upload!("latest.zip", REMOTE_PATH + "latest.zip") en...

0
голосов
2ответов
253 просмотров

Куда вы должны устанавливать драгоценные камни с Rubygems для разработки?

Если вы не устанавливаете гемы с sudo на Mac, по умолчанию они будут помещены в каталог, например .gem/ruby/1.8/gems/ Если вы ДЕЙСТВИТЕЛЬНО устанавливаете с помощью sudo, насколько я понимаю, они обычно размещаются в системных каталогах, например: /usr/local/lib/ruby/gems/1.8/gems/ ...

12
голосов
7ответов
11620 просмотров

Best YouTube gem for Ruby?

Is there a definitive gem for the YouTube API? I'm trying to use youtube_g, but it seems to break on some basic stuff.

59
голосов
2ответов
10400 просмотров

Forking a gem for a Rails project

I've found myself twice in this situation: I install a gem on my system and start using it from my Rails project. Eventually I need to make some changes to that gem. How should I proceed? Ideally I'd like to check out the source code of that gem somewhere, like ~/third_party/gems, work on it and...

0
голосов
3ответов
808 просмотров

ruby on rails 1.2.6 and ActiveMerchant

I am trying to run ActiveMerchant gem with old version of Rails (1.2.6). And if I require active_merchant gem i get this error: config/boot.rb:17:Warning: Gem::SourceIndex#search support for String patterns is deprecated, use #find_name /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:280:in `acti...

3
голосов
3ответов
4622 просмотров

How to specify rubygems path in environment-less Ruby script?

I've written a data collection script for Cacti in Ruby and it runs fine from the command line but Cacti runs the script via "env -i" which strips the environment so Ruby can't find the rubygems library ("in `require': no such file to load -- rubygems (LoadError)"). How might I work around this?

2
голосов
6ответов
3353 просмотров

require library returns 'missing file' message

I have a small application which I created using jeweler. The jeweler generates a lib/ directory, where I suppose to write my code. This gem I'm creating depends on the httparty gem, so, in my Rakefile I put Jeweler::Tasks.new do |gem| gem.add_dependency('httparty', '>= 0.4.5') .....

1
голосов
3ответов
711 просмотров

OAauth gem in rails problem

I'm trying out OAuth for twitter api authentication and ran into a brick wall when my code spits out the message: (instance of OAuth::Consumer needs to have method `marshal_load') My code: @consumer=OAuth::Consumer.new( "token","secret", { :site=>"http://mysite.com/" }) @request_tok...

0
голосов
3ответов
157 просмотров

Is Rails-2.3 stable? Does anyone have any problems with it?

I want to develop an application in Ruby on Rails. I have used rails(vigorously) a couple of years ago. since then i haven't given it a try, i have been concentrating on core ruby. At that time, Rails(1.2.x) used to be a bit slow! so my problem is whether i should go for the earlier slower versio...

7
голосов
4ответов
1890 просмотров

How to distribute a Ruby application with the required gems

I've developed a Ruby application (a small game), and I would like to 'distribute' it to other people. However, I am not sure what to do about the required gems. If I just send my application to someone who have ruby installed, but not the required gems, I assume it will blow up. Can I package ...

12
голосов
5ответов
4197 просмотров

256 color terminal library for Ruby?

Is there a gem like 'Term::ANSIColor' which works with 256 color terminals? The perl script 256colors2.pl works great in my terminal, and I'd like to use some of these colors in my ruby scripts without manually inserting the ANSI codes.

17
голосов
3ответов
8600 просмотров

Is it possible to download a Ruby gem without installing it automatically?

When I download something using gem I'd like to be able to just download the gem, and then choose whether or not I want to install it. I'm asking this because I'd like to install a particular gem on more than one computers ( without installing from the internet on each one ).

1
голосов
3ответов
1291 просмотров

Gem update fails, no Xcode

I ran sudo gem update earlier today and was thrilled to see it work, but at the end it failed. Building native extensions. This could take a while... ERROR: While executing gem ... (Gem::Installer::ExtensionBuildError) ERROR: Failed to build gem native extension. ruby extconf.rb update can'...

2
голосов
1ответов
317 просмотров

Having problems with net::ssh::multi can't require it! Ruby

So I've tried to install net::ssh::multi on mac using gems: gems install net-ssh-multi The installation went fine, however when I type: require 'net/ssh/multi' it says load error. I have no idea whats wrong with what I'm doing!

2
голосов
2ответов
1166 просмотров

MySQL Ruby Gem on OS X Snow Leopard

I've been fighting with getting the MySQL Ruby Gem up and running on Snow Leopard for the past couple of days. I have tried all different sorts of things to get this working, and currently have MySQL 5.1.37 x64 installed. After fighting to even get the Gem installed I believe that I finally got ...

5
голосов
2ответов
3364 просмотров

How to replace the Unicode gem on Ruby 1.9?

Unfortunately, the Unicode 0.1 (sudo gem install unicode) doesn't work on Ruby 1.9. I have the following snippet: require "rubygems" require "unicode" str = "áéíóúç" Unicode.normalize_KD(str).gsub(/[^\x00-\x7F]/n, "") #=> aeiouc I use it to convert titles to permalink, without removing acc...

1
голосов
2ответов
1071 просмотров

Is it possible to update model attributes using Ohm and Redis DB is Ruby?

I'm taking a first look at Monk and the Ohm/Redis APIs and I have a simple question. Is it possible to update attributes on model objects using Ohm/Redis? class Event < Ohm::Model attribute :name index :name end Event.create(:name => "A mistake made here...") @event = Event.find(:id...

0
голосов
1ответов
78 просмотров

What are the pitfalls and solutions when setting up Rails/Mysql on Leopard?

I've been going stir crazy trying to install the ruby mysql gem here, and I'm writing here so if anyone else is in this ridiculous situation, they don't have to go through the same pain as me. What are the common gotchas when installing the mysql gem onto a fresh copy of Leopard? In this case,...

3
голосов
2ответов
1657 просмотров

error while installing ruby gem

I am trying to install a ruby gem. I am getting this error. C:12321gt;gem install racc Building native extensions. This could take a while... ERROR: Error installing racc: ERROR: Failed to build gem native extension. c:/ruby/bin/ruby.exe extconf.rb install racc extconf.rb:3:in ``': No...

1
голосов
3ответов
467 просмотров

Best way to install mulitple gems onto a computer?

Is there an easy way, when running a Ruby script, to get it to automatically install gems required for script? For example, consider these require statements at the top of a ruby script: require 'net/http' require 'fileutils' require 'archive/zip' Now, I know (as a human and programmer) that ...